Dell Dimension C521 Service Manual
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CAUTION: Before you begin any of the procedures in this section, follow the safety instructions in the Product Information Guide. |
If you experience a problem with your computer, perform the checks in this section and run the Dell Diagnostics before you contact Dell for technical assistance.
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NOTICE: The Dell Diagnostics works only on Dell computers. |
If you wait too long and the operating system logo appears, continue to wait until you see the Microsoft® Windows® desktop. Then shut down your computer and try again.
If you cannot resolve the error condition, contact Dell. For information about contacting Dell, see your Owner's Manual.
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NOTE: The Service Tag for your computer is located at the top of each test screen. If you contact Dell, technical support will ask for your Service Tag. |
Close the test screen to return to the Main Menu screen. To exit the Dell Diagnostics and restart the computer, close the Main Menu screen.
Your power button light and hard-drive activity light may indicate a computer problem.
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Power Light |
Problem Description |
Suggested Resolution |
|---|---|---|
Off | The computer is in a normal "off" condition or in a power-conserving mode. | None. Press the power button to wake the computer or to turn the computer on. |
Solid green | The computer has successfully booted and is operating normally. | None. |
Blinking green | The computer is in a Windows standby power-saving state (S1 or S3). | None. Move the mouse, press the spacebar, or use another device that has been configured as a wake-up device to wake the computer. |
Solid Amber | A pre-POST failure has occurred. The system has received a Power Good signal from the power supply. | See Diagnostic Lights for more information. If this does not resolve your problem, contact Dell. For information about contacting Dell, see your Owner's Manual. |
Blinking Amber | A possible power supply failure has occurred. The system has not received a Power Good signal from the power supply | Plug the computer into a working electrical outlet. |
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CAUTION: Before you begin any of the procedures in this section, follow the safety instructions in the Product Information Guide. |
To help you troubleshoot a problem, your computer has four lights labeled "1," "2," "3," and "4" on the front panel. When the computer starts normally, the lights flash. After the computer starts, all four lights display solid green. If the computer malfunctions, the color and sequence of the lights identify the problem.
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Light Pattern |
Problem Description |
Suggested Resolution |
|---|---|---|
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| The computer is in a normal condition or a possible pre-POST failure has occurred. | See System Lights. |
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| The computer is in recovery mode. | None. |
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| A possible processor failure was detected. | Contact Dell. For information about contacting Dell, see your Owner's Manual. |
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| Memory modules are detected, but a memory failure has occurred. |
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| A possible graphics failure has occurred. | If the problem persists, contact Dell. For information about contacting Dell, see your Owner's Manual. |
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| A possible floppy drive or hard drive failure has occurred. | Reseat all power and data cables and restart the computer. |
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| A possible USB failure has occurred. | Reinstall all USB devices, check cable connections, and then restart the computer. |
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| No memory modules are detected. |
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| Memory modules are detected, but a memory configuration or compatibility error exists. |
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| A possible expansion card failure has occurred. |
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| Routine system activity subsequent to video initialization. | Watch your monitor for on-screen messages. |
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| System resource configuration in progress. | None. |
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| System board failure has occurred. | Contact Dell. For information about contacting Dell, see your Owner's Manual. |
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| During normal operation, all of the diagnostic lights turn on and then turn off before the system starts. NOTE: If all of the diagnostic lights are on and the system does not start, there may be a problem with the power supply or with the processor. | If the system does not start, plug the computer into a working electrical outlet. Also see System Lights. If there are no power problems and the system does not start, contact Dell. For information about contacting Dell, see your Owner's Manual. |
Your computer might emit a series of beeps during start-up if the monitor cannot display errors or problems. This series of beeps, called a beep code, identifies a problem. One possible beep code consists of one long beep and then two short beeps. This beep code tells you that the computer encountered a memory test failure.
If your computer beeps during start-up:
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Code |
Cause |
|---|---|
2 short, 1 long | BIOS checksum error |
1 long, 2 short | Memory test failure (bad memory during memory sizing) |
1 long, 3 short, 2 short | No memory |
1 short | F12 key pressed |