To help you troubleshoot a problem, your computer is equipped with four lights on the back panel labeled "A," "B," "C," and "D." These lights can be yellow or green. When the computer starts normally, the lights flash. After the computer starts, the lights remain green. If the computer malfunctions, the color and sequence of the lights identify the problem.
CAUTION: Before you begin any of the procedures in this section, follow the safety instructions in your Owner's Manual.
Light Pattern
Problem Description
Suggested Resolution
The computer is in a normal off condition or a possible pre-BIOS failure has occurred.
Verify that the computer power cable is plugged into the computer and a working electrical outlet. Press the power button.
Other failure has occurred.
Ensure that the cables are properly connected from the hard drive, CD drive, and DVD drive to the system board.
If the problem persists, contact Dell. See your Owner's Manual for contact information.
A possible expansion card failure has occurred.
Determine if a conflict exists by removing a card (not the video card) and then restarting the computer.
If the problem persists, reinstall the card that you removed, remove a different card, and then restart the computer.
Repeat this process for each card. If the computer starts normally, troubleshoot the last card you removed from the computer for resource conflicts (see "Resolving Software and Hardware Incompatibilities").
If the problem persists, contact Dell. See your Owner's Manual for contact information.
Memory modules are detected, but a memory failure has occurred.
Remove and reinstall all memory modules and CRIMMs. Ensure that all the connector tabs are locked. Restart the computer.
Install the memory modules in memory connectors RIMM1 (located closest to the microprocessor) and RIMM2 and ensure that, if no additional memory is used, CRIMMs are installed in memory connectors RIMM3 and RIMM4.
If you installed memory modules in memory connectors RIMM3 and RIMM4 that were not purchased from Dell, remove the modules and replace them with the CRIMMs that were originally installed in your computer.
If available, install Dell memory of the same type into your computer.
If the problem persists, contact Dell. See your Owner's Manual for contact information.
A possible microprocessor failure has occurred.
Reinstall the microprocessor and restart the computer.
Memory modules are detected, but a memory configuration or compatibility error exists.
Ensure that there are no special memory module/memory connector placement requirements (see "Adding Memory").
Verify that the memory modules that you are installing are compatible with your computer. See "Memory" in the "Technical Specifications."
Reinstall the memory modules and restart the computer.
If the problem persists, contact Dell. See your Owner's Manual for contact information.
A possible floppy or hard drive failure has occurred.
Check all power and data cable connections and restart the computer.
No memory modules are detected.
Reinstall all memory modules and restart the computer.
If the problem persists, contact Dell. See your Owner's Manual for contact information.
A possible BIOS failure has occurred; the computer is in the recovery mode.
Run the BIOS Recovery Utility, wait for recovery completion, and then restart the computer.
A possible video card failure has occurred or a bad on-board video exists.
If the computer has a video card, remove the card and reinstall it.
If the problem persists or the computer has integrated video, contact Dell. See your Owner's Manual for contact information.
A possible USB failure has occurred.
Resinstall all USB devices, check cable connections, and then restart the computer.
The computer is in a normal operating condition after POST.
Your computer might emit a series of beeps during start-up if the monitor cannot display errors or problems. This series of beeps, called a beep code, identifies a problem. One possible beep code (code 1-3-1) consists of one beep, a burst of three beeps, and then one beep. This beep code tells you that the computer encountered a memory problem.
Reseating the memory modules may fix the beep code errors in the following table. If the problem persists, see "Contacting Dell" in your Owner's Manual for instructions on obtaining technical assistance.
Code
Cause
1-3-1 through 2-4-4
Memory not being properly identified or used
4-3-1
Memory failure above address 0FFFFh
If you hear one of the following beep codes, see "Contacting Dell" in your Owner's Manual for instructions on obtaining technical assistance.
HINT: If the message you
received is not listed in
the table, see the
documentation for either
the operating system or
the program that was
running when the message
appeared.
Message
Possible Cause
Corrective Action
8042 Gate-A20 error
The keyboard controller failed its test.
If you receive this message after you make changes in the system setup program, enter the program and restore the original value(s).
Address Line Short!
An error in the address decoding circuitry in the memory has occurred.
The hard drive is not working or is not configured correctly.
Ensure that the drive is installed correctly in the computer and defined correctly in the system setup program.
Cache Memory Bad, Do Not Enable Cache
The cache memory is not operating.
See "Contacting Dell" in your Owner's Manual for instructions on obtaining technical assistance.
CH-2 Timer Error
An error is occurring on the timer on the system board.
See "Contacting Dell" in your Owner's Manual for instructions on obtaining technical assistance.
CMOS Battery State Low
CMOS Checksum Failure
CMOS System Options Not Set
CMOS Display Type Mismatch
CMOS Memory Size Mismatch
CMOS Time and Date Not Set
The system configuration information in the system setup program is incorrect or the battery charge may be low.
Enter the system setup program, verify the system configuration, and then restart the computer.
Diskette Boot Failure
Drive A or B is present but has failed the BIOS POST.
Ensure that the drive is installed correctly in the computer and defined correctly in the system setup program. Check the interface cable at both ends.
DMA Error
DMA 1 Error
DMA 2 Error
Error in the DMA controller on the system board.
The keyboard or system board may need to be replaced.
FDD Controller Failure
HDD Controller Failure
The BIOS cannot communicate with the floppy drive or hard drive controller.
Ensure that the floppy drive or the hard drive is installed correctly in the computer and defined correctly in the system setup program. Check the interface cable at both ends.
INTR1 Error
INTR2 Error
An interrupt channel on the system board failed to POST.
The keyboard or system board may need to be replaced.
Invalid Boot Diskette
The operating system cannot be located on drive A or drive C.
Enter the system setup program and confirm that drive A or drive C is properly identified.
Keyboard Error
The BIOS has detected a stuck key.
Ensure that nothing is resting on the keyboard; if a key appears to be stuck, carefully pry it up. If the problem persists, you may need to replace the keyboard.
KB/Interface Error
An error occurred with the keyboard connector.
Ensure that nothing is resting on the keyboard; if a key appears to be stuck, carefully pry it up. If the problem persists, you may need to replace the keyboard.
No ROM Basic
The operating system cannot be located on drive A or drive C.
Enter the system setup program and confirm that drive A or drive C is properly identified.
A driver is a program that controls a device such as a printer, mouse, or keyboard. All devices require a driver program.
A driver acts like a translator between the device and the programs that use the device. Each device has its own set of specialized commands that only its driver recognizes.
Many drivers, such as the keyboard driver, come with your Microsoft® Windows® operating system. You may need to install drivers if you:
Upgrade your operating system
Reinstall your operating system
Connect or install a new device
If you experience a problem with any device, perform the steps in the following sections to identify whether the driver is the source of your problem and if necessary, to update the driver.
NOTICE: The Dell Support website and your Dell Dimension ResourceCD
provide approved drivers for Dell computers. If you install drivers obtained
from other sources, your computer might not work correctly.
If a problem occurs on your computer after you install or update a driver, use Windows XP Device Driver Rollback to replace the driver with the previously installed version.
To use Device Driver Rollback:
Click the Start button and click Control Panel.
In the Control Panel window, under Pick a Category, click
Performance and Maintenance.
In the Performance and Maintenance window, click System.
In the System Properties window, click the Hardware tab.
Click Device Manager.
In the Device Manager window, right-click the device for which the
new driver was installed and click Properties.
Click the Drivers tab.
Click Roll Back Driver.
If Device Driver Rollback does not resolve the problem, then use System Restore to return your computer to the operating state that existed before you installed the new driver.
With the Windows desktop displayed, insert the ResourceCD into the
CD or DVD drive.
If this is your first time to use the ResourceCD, go to step 2. If not, go to step 5.
When the ResourceCD installation program starts, follow the prompts
on the screen.
When the InstallShield Wizard Complete window appears, remove
the ResourceCD and click Finish to restart the computer.
When you see the Windows desktop, reinsert the ResourceCD into
the CD or DVD drive.
At the Welcome Dell System Owner screen, click Next.
HINT: The ResourceCD
displays drivers only for
hardware that came on
your computer. If you
installed additional
hardware, the drivers for
the new hardware might
not be displayed by the
ResourceCD. If those
drivers are not displayed,
exit the ResourceCD
program. For drivers
information, see the
documentation that came
with the device.
A message stating that the ResourceCD is detecting hardware in your computer appears.
The drivers that are used by your computer are automatically displayed in the My DriversThe ResourceCD has identified these components in your system window.
Click the driver that you want to reinstall and follow the instructions
on the screen.
If a particular driver is not listed, then that driver is not required by your operating system.
The Microsoft® Windows® XP operating system provides System Restore to allow you to return your computer to an earlier operating state (without affecting data files) if changes to the hardware, software, or other system settings have left the computer in an undesirable operating state. See Windows Help for information on using System Restore. To access Windows Help, see "Finding Help Information."
NOTICE: Make regular backups of your data files. System Restore does not
monitor your data files or recover them.
If problems occur after you install a device driver, use Device Driver Rollback to resolve the problem. If that is unsuccessful, then use System Restore.
NOTICE: Before you restore the computer to an earlier operating state, save
and close all open files and close all open programs. Do not alter, open, or
delete any files or programs until the system restoration is complete.
Click the Start button, point to All Programs® Accessories® System
Tools, and then click System Restore.
Ensure that Restore my computer to an earlier time is selected and
click Next.
Click a calendar date to which you want to restore your computer.
The Select a Restore Point screen provides a calendar that allows you to see and select restore points. All calendar dates with available restore points appear in bold.
Select a restore point and click Next.
If a calendar date has only one restore point, then that restore point is automatically selected. If two or more restore points are available, click the restore point that you prefer.
Click Next.
The Restoration Complete screen appears after System Restore finishes collecting data and then the computer restarts.
After the computer restarts, click OK.
To change the restore point, you can either repeat the steps using a different restore point, or you can undo the restoration.
NOTICE: Before you undo the last system restore, save and close all open
files and close all open programs. Do not alter, open, or delete any files or
programs until the system restoration is complete.
Click the Start button, point to All Programs® Accessories® System
Tools, and then click System Restore.
Click Undo my last restoration and click Next.
Click Next.
The System Restore screen appears and the computer restarts.
If you reinstall Windows XP with less than 200 MB of free hard-disk space available, System Restore is automatically disabled. To see if System Restore is enabled:
If you are reinstalling the Windows XP operating system to correct a problem with a newly installed driver, use Windows XP Device Driver Rollback to replace the device driver with the previously installed version.
If Device Driver Rollback does not resolve the problem, then use System Restore to return your operating system to the operating state it was in before you installed the new device driver.
To reinstall Windows XP, perform the steps in the following sections in the order in which they are listed.
The reinstallation process can take 1 to 2 hours to complete. After the reinstallation is complete, you need to reinstall the device drivers, virus protection program, and other software.
NOTICE: The Operating System CD provides options for reinstalling Windows
XP. The options can overwrite files and possibly affect programs installed on
your hard drive. Therefore, do not reinstall Windows XP unless instructed to
do so by a Dell technical support representative.
NOTICE: To prevent conflicts with Windows XP, disable any virus protection
software installed on your computer before you reinstall Windows XP. See the
documentation that came with the software for instructions.
When the Windows XP Setup screen appears, press <Enter> to
select To set up Windows now.
Read the information in the Microsoft Windows Licensing
Agreement screen, and then press <F8> to accept the license
agreement.
If your computer already has Windows XP installed and you want to
recover your current Windows XP data, type r to select the repair
option, and then remove the CD from the drive.
If you want to install a new copy of Windows XP, press <Esc> to
select the fresh copy option.
Press <Enter> to select the highlighted partition (recommended),
and then follow the instructions on the screen.
HINT: The time required
to complete the setup
depends on the size of the
hard drive and the speed
of your computer.
The Windows XP Setup screen appears, and the operating system begins to copy files and install the devices. The computer restarts multiple times.
NOTICE: When the computer restarts, the following message appears:
Press any key to boot from the CD.Do not press any key when this
message appears.
When the Regional and Language Options screen appears, select the
settings for your location and click Next.
Enter your name and organization (optional) in the Personalize Your
Software screen and click Next.
If you are reinstalling Windows XP Home Edition, at the What's your
computer's name window, enter a name for your computer (or accept
the name provided) and click Next.
If you are reinstalling Windows XP Professional, at the Computer Name and Administrator Password window, enter a name for your computer (or accept the one provided) and a password, and then click Next.
If you have a modem installed, enter the requested information and
click Next when the Modem Dialing Information screen appears.
Enter the date, time, and time zone in the Date and Time Settings
window and click Next.
If your computer has a network adapter, click Typical in the Networking
Settings screen and click Next.
If your computer does not have a network adapter, this option does not appear.
If you are reinstalling Windows XP Professional, you may be prompted
to provide further network information regarding your network
configuration, such as the domain name or workgroup name. If you are
unsure of your settings, accept the default selections.
Windows XP installs the operating system components, configures the computer, and then restarts the computer.