The power button light located on the front of your computer illuminates and blinks or remains solid to indicate different states:
If the power light is green and the computer is not responding, see "Diagnostic Lights."
If the power light is blinking green, the computer is in standby mode. Press a key on the keyboard, press the power button, or move the mouse to resume normal operation.
If the power light is off, the computer is either turned off or is not receiving power.
Reseat the power cable into both the power connector on the back of the computer and the electrical outlet.
If the computer is plugged into a power strip, ensure that the power strip is plugged into an electrical outlet and that the power strip is turned on. Also bypass power protection devices, power strips, and power extension cables to verify that the computer turns on properly.
Ensure that the electrical outlet is working by testing it with another device, such as a lamp.
Ensure that the main power cable and front panel cable are securely connected to the system board.
If the power light is blinking amber, the computer is receiving electrical power, but an internal power problem might exist.
Ensure that the voltage selection switch is set to match the AC power at your location (if applicable). See your Owners Manualfor more information.
Ensure that the processor power cable is securely connected to the system board. See your Owners Manual for more information.
If the power light is steady amber, a device might be malfunctioning or incorrectly installed.
Remove and then reinstall the graphics card, if applicable.
Eliminate sources of interference. Some possible causes of interference are:
Power, keyboard, and mouse extension cables
Too many devices on a power strip
Multiple power strips connected to the same electrical outlet
Network Lights
CAUTION: Before you begin any of the procedures in this section, follow the safety instructions in the Product Information Guide.
Check the network cable connector to ensure that the network cable is firmly inserted into both the network connector on the back of the computer and the network jack.
Check the network lights on the back of the computer. If the link integrity light is off, that indicates no network communication exists. Replace the network cable. For a description of network lights, see your Owner's Manual.
Restart the computer and log on to the network again.
Check your network settings. Contact your network administrator or the person who set up your network to verify that your network settings are correct and that the network is functioning.
Run the Hardware Troubleshooter. See your Owner's Manual.
Diagnostic Lights
CAUTION: Before you begin any of the procedures in this section, follow the safety instructions in the Product Information Guide.
To help you troubleshoot a problem, your computer has four lights labeled "A," "B," "C," and "D" on the back panel (see your Owner's Manual). The lights can be yellow or green. When the computer starts normally, the lights flash. After the computer starts, all four lights display solid green. If the computer malfunctions, the color and sequence of the lights identify the problem.
Light Pattern
Problem Description
Suggested Resolution
The computer is in a normal "off" condition or a possible pre-BIOS failure has occurred.
Plug the computer into a working electrical outlet and press the power button.
A possible processor failure has occurred.
Contact Dell (see your Owner's Manual).
Memory modules are detected, but a memory failure has occurred.
If you have two or more memory modules installed, remove the modules, reinstall one module (see your Owner's Manual), and then restart the computer. If the computer starts normally, reinstall an additional module. Continue until you have identified a faulty module or reinstalled all modules without error.
If available, install properly working memory of the same type into your computer (see your Owner's Manual).
If the problem persists, contact Dell (see your Owner's Manual).
A possible graphics card failure has occurred.
If the computer has a graphics card, remove the card, reinstall it (see your Owner's Manual), and then restart the computer.
If the problem still exists, install a graphics card that you know works and restart the computer.
If the problem persists or the computer has integrated graphics, contact Dell (see your Owner's Manual).
A possible floppy or hard drive failure has occurred.
Reseat all power and data cables and restart the computer.
A possible USB failure has occurred.
Reinstall all USB devices, check cable connections, and then restart the computer.
No memory modules are detected.
If you have two or more memory modules installed, remove the modules, reinstall one module (see your Owner's Manual), and then restart the computer. If the computer starts normally, reinstall an additional module. Continue until you have identified a faulty module or reinstalled all modules without error.
If available, install properly working memory of the same type into your computer (see your Owner's Manual).
If the problem persists, contact Dell (see your Owner's Manual).
Memory modules are detected, but a memory configuration or compatibility error exists.
Ensure that no special memory module/memory connector placement requirements exist (see your Owner's Manual).
Verify that the memory modules that you are installing are compatible with your computer (see your Owner's Manual).
If the problem persists, contact Dell (see your Owner's Manual).
A possible expansion card failure has occurred.
Determine if a conflict exists by removing a card (not a graphics card) (see your Owner's Manual) and restarting the computer.
If the problem persists, reinstall the card that you removed, remove a different card, and then restart the computer.
Repeat this process for each card. If the computer starts normally, troubleshoot the last card removed from the computer for resource conflicts (see your Owner's Manual).
If the problem persists, contact Dell (see your Owner's Manual).
Another failure has occurred.
Ensure that the cables are properly connected to the system board from the hard drive, CD drive, and DVD drive (see your Owner's Manual).
If there is an error message on your screen identifying a problem with a device (such as the floppy drive or hard drive), check the device to make sure it is functioning properly.
The operating system is attempting to boot from a device (such as the floppy drive or hard drive); check system setup (see your Owner's Manual) to make sure the boot sequence is correct for the devices installed on your computer.
If the problem persists, contact Dell (see your Owner's Manual).
The computer is in a normal operating condition after POST.
None.
Beep Codes
Your computer might emit a series of beeps during start-up if the monitor cannot display errors or problems. This series of beeps, called a beep code, identifies a problem. One possible beep code (code 1-3-1) consists of one beep, a burst of three beeps, and then one beep. This beep code tells you that the computer encountered a memory problem.
Reseating the memory modules may fix the beep code errors listed in the following table. If the problem persists, see "Contacting Dell" in your Owner's Manual for instructions on obtaining technical assistance.
Code
Cause
1-3-1 through 2-4-4
Memory not being properly identified or used
4-3-1
Memory failure above address 0FFFFh
If you hear one of the beep codes listed in the following table, see "Contacting Dell" in your Owner's Manual for instructions on obtaining technical assistance.
Code
Cause
1-1-2
Microprocessor register failure
1-1-3
NVRAM
1-1-4
ROM BIOS checksum failure
1-2-1
Programmable interval timer
1-2-2
DMA initialization failure
1-2-3
DMA page register read/write failure
3-1-1
Slave DMA register failure
3-1-2
Master DMA register failure
3-1-3
Master interrupt mask register failure
3-1-4
Slave interrupt mask register failure
3-2-2
Interrupt vector loading failure
3-2-4
Keyboard Controller Test failure
3-3-1
NVRAM power loss
3-3-2
NVRAM configuration
3-3-4
Video Memory Test failure
3-4-1
Screen initialization failure
3-4-2
Screen retrace failure
3-4-3
Search for video ROM failure
4-2-1
No timer tick
4-2-2
Shutdown failure
4-2-3
Gate A20 failure
4-2-4
Unexpected interrupt in protected mode
4-3-3
Timer-chip counter 2 failure
4-3-4
Time-of-day clock stopped
4-4-1
Serial or parallel port test failure
4-4-4
Cache test failure
System Messages
NOTE: If the message you received is not listed in the following table, see the documentation for either the operating system or the program that was running when the message appeared.
Message
Possible Cause
Corrective Action
8042 Gate-A20 error
The keyboard controller failed its test.
If you receive this message after you make changes in the system setup program, enter the system setup program and restore the original value.
Address Line Short!
An error in the address decoding circuitry in the memory has occurred.
If the battery charge is low, replace the battery. (See "Battery" in your Owner's Manual.)
CPU Fan failure
The fan has stopped spinning or is spinning too slowly.
Check the fan to see if anything is stopping or slowing it down.
Previous Fan Failure
The fan stopped spinning or is spinning too slowly. This event happened sometime during normal operation before the last boot.
Check the fan to see if anything is stopping or slowing it down.
Diskette Boot Failure
Drive A or B is present but has failed the BIOS POST.
Ensure that the drive is installed correctly in the computer and defined correctly in the system setup program. Check the interface cable at both ends.
DMA Error
DMA 1 Error
DMA 2 Error
An error occurred in the DMA controller on the system board.
The keyboard or system board may need to be replaced.
FDD Controller Failure
HDD Controller Failure
The BIOS cannot communicate with the floppy drive or hard drive controller.
Ensure that the floppy drive or the hard drive is installed correctly in the computer and defined correctly in the system setup program. Check the interface cable at both ends.
INTR1 Error
INTR2 Error
An interrupt channel on the system board failed to POST.
The keyboard or system board may need to be replaced.
Invalid Boot Diskette
The operating system cannot be located on drive A or drive C.
Ensure that nothing is resting on the keyboard; if a key appears to be stuck, carefully pry it up. If the problem persists, you may need to replace the keyboard.
KB/Interface Error
An error occurred with the keyboard connector.
Ensure that nothing is resting on the keyboard; if a key appears to be stuck, carefully pry it up. If the problem persists, you may need to replace the keyboard.
No ROM Basic
The operating system cannot be located on drive A or drive C.