===============================================================
Dell(TM) PowerVault(TM) 745N Network Attached Storage (NAS)
System Release Notes for Operating System Version 3.4.9.x
===============================================================
This document contains information updating your
Dell PowerVault 745N NAS System Administrator's
Guide and any other technical documentation included with this
product. It includes the following information:
* Reinstallation CDs and Resource CD Major Changes and
Versions
* Managing UPS Services Through the NAS Manager
* 1 TB Limit When Upgrading to Dynamic Disk
* Shadow Copy Percent Used in NAS Manager
* Enabling Automatic Update
* RAID Controller Boot Order
* Found New Hardware Window Displays During
Reinstallation
* Enabling the Screen Saver with Windows Storage Server
2003
* Errors Occur When Running the NAS Reinstallation
Console
* Incorrect LED Status Displays After Hot-Plugging a
Hard Drive
* USB Key Preparation Utility Does Not Recognize the USB Key
* Event Log Indicates LDM Service Failure, VDS Provider
Failure
* Selecting the Boot Operating System
* Rsass.exe Error
* Cannot Update SCSI Hard Drive Firmware on
PowerVault 745N NAS System
* USB Key Preparation Utility Changed the USB Key
Capacity to 55MB
* On a System with DRAC 3/XT
Menus or Dialogs Boxes May Display Junk Characters
* Update.bat file does not exist
* Dell OpenManage Server Administrator Link on the NAS
Manager Does Not Work
* Remote Console using the Remote Access Controller is
not available on PV745N
===============================================================
Reinstallation CDs and Resource CD Major Changes and
Versions
===============================================================
+--------------------------------------------------------------------------------------------+
| Release
Date | Component
| Version | Major Component
Changes |
+--------------------------------------------------------------------------------------------+
3/22/2004
| Reinstallation CDs |
3.4.9.0 | OpenManage 3.7.1
software components:
* Server Administrator 1.7.1
*
ArrayManager 3.5
* Server Assistant 4.12.1
* Online Diagnostics (OL-D) 2.7
* Local Update Service 1.8
* Remote Access Controller (RAC) 3.0
---------------------------------------------------------------------------------------------------
3/22/2004
| Resource CD |
3.4.9.0 | Documentation:
* OpenManage
version 3.71
* ArrayManager version 3.5
---------------------------------------------------------------------------------------------------
12/6/2004
| Resource CD |
3.4.9.1 | Documentation
changes:
* New OpenManage version 4.1
*
ArrayManager version 3.6
USB Key Prep Utility to accommodate
new USB keys
---------------------------------------------------------------------------------------------------
3/28/2005
| Reinstallation CDs | 3.4.9.1 |
Update OpenManage 3.71 --> OpenManage 4.1
OpenManage 4.1 software components:
* Server Administrator 1.9
* ArrayManager 3.6
* Server Assistant 5.2
* Online Diagnostics (OL-D) 3.1
* Local Update Service 1.9.1
* Remote Access Controller (RAC) 3.3
---------------------------------------------------------------------------------------------------
10/10/2005 | Reinstallation CDs | 3.4.9.2 | Update
to Windows Server 2003 Service Pack 1
Update OpenManage 4.1 --> OpenManage 4.4
OpenManage 4.4 software components:
| Resource CDs | 3.4.9.2 |
Documentation changes:
OpenManager version 4.4
Array Manager 3.7
PV745N Information Update Tech Sheet
---------------------------------------------------------------------------------------------------
===============================================================
Managing UPS Services Through the NAS Manager
===============================================================
Problem:
When starting/stopping the UPS management service, the system generates
a 413E010D
UPS CONFIGURATION error message on the NAS Manager Status page and
required the
system to be rebooted to clear.
Solution:
When managing a UPS attached to the NAS system through
the NAS Manager, always use the
Maintenance--> UPS link to configure and start the UPS management
service. Using any other
link to start/stop the UPS services may generate an error.
===============================================================
1 TB Limit When Upgrading to Dynamic Disk
===============================================================
Problem:
When trying to convert any disk over 1 TB to dynamic using Disk Management
(LDM), an error
message states that the operation did not complete and to check the system
event log for more
information. However, no error appears in the event log
Cause:
Disk Management currently does not allow you to upgrade disks larger than 1
TB to dynamic disks.
Solution:
A Knowledge Base article that discusses this issue and gives information on
how to obtain a fix.
Search for Knowledge Base article 826823 on www.microsoft.com for
more information.
Also, you can use the DISKPART utility to convert disks larger than 1 TB to
dynamic.
===============================================================
Shadow Copy Percent Used in NAS Manager
===============================================================
Problem:
In the column for percent used on the Shadow Copies page, the
percentage of space appears
to be inaccurate.
Solution:
To see how much space Shadow Copies are using, select a
volume, and then select Properties.
This page displays the space used by Shadow Copies on that volume.
===============================================================
Enabling Automatic Update
===============================================================
Problem:
Automatic Update is not working.
Cause:
Automatic Update is disabled by default on your NAS system.
Solution:
Enable Automatic Update by performing the following steps:
1.
Click Remote Desktop under the Maintenance tab in the
NAS Manager.
2.
Log into the NAS system as an administrator.
3.
On the NAS system desktop, right-click My Appliance, and then
click Properties.
4.
Click the Automatic Updates tab to configure Automatic Update.
===============================================================
RAID Controller Boot Order
===============================================================
Problem:
After reinstalling the operating system image, the NAS system uses the
PowerEdgeÔ Expandable
RAID Controller (PERC) x/DC or PERC 3/DC RAID controller, rather than the internal RAID
controller.
Cause:
The boot device order in the System Setup program was manually modified to
make the PERC
RAID controller the first boot option, and the PERC RAID controller BIOS is
enabled.
Solution:
Do not put the PERC RAID controller as the first boot option and do not
enable the PERC RAID
controller BIOS. Enter the System Setup Program and set the boot order to
the defaults by pressing
CTRL-F. See your Users Guide for more information on using the
System Setup
program. To disable the BIOS of the PERC RAID controller, use the RAID
controllers BIOS
Configuration Utility. See your PERC documentation for more information
===============================================================
Updated System Depth
===============================================================
Issue:
The system depth documented in your systems User's Guide is
incorrect. The correct depth
of the system with the optional bezel is 63.0 cm (24.8 inches)
===============================================================
Using DSET to Access System Information
===============================================================
DSET is a Dell-developed tool that allows you to access information about
system components,
firmware, and driver versions. After every reinstall, a DSET report is
automatically generated for
your NAS system.
NOTE: When you update system components such as drivers or
firmware, you must generate a
new DSET report to reflect these updates.
To create a DSET report, use a keyboard, monitor, and mouse connected to
your NAS system
to log in, or log in remotely using Terminal Services. At the command
prompt, enter the following
command:
C:\Program Files\Dell\DSET\bin\systeminfo.bat
===============================================================
Found New Hardware Window Displays During Reinstallation
===============================================================
Problem:
During reinstallation, a Found New Hardware window may display,
prompting you to restart
the system.
Cause:
In a previous boot, the operating system disk was upgraded to dynamic.
Solution:
Ignore the window, and select No. The system restarts automatically
after it has completed the
reinstallation. Take no other action.
===============================================================
Enabling the Screen Saver with Windows Storage Server 2003
===============================================================
Problem:
In the Microsoft® Windows®
Storage Server 2003 operating system, you cannot enable the screen
saver in the Display Properties dialog of the Control Panel.
Cause:
The screen saver is disabled by default on your NAS system.
Solution:
You can re-enabled the screen saver by using the MMC group policy editor (gpedit.msc).
To
re-enable the screen savers, perform the following steps:
1.
Click Remote Desktop on the Maintenance page in the NAS
Manager.
2.
Log into the NAS system as an administrator.
3.
On the NAS system desktop, click Start -> Run.
4.
Type gpedit.msc in the Open text box and click OK.
5.
When Group Policy Object Editor opens, expand User
Configuration in the left pane.
6.
Expand Administrative Templates.
7.
Expand Control Panel.
8.
Select Display.
9.
In the right pane, double click Screen Saver.
Select Not Configured or Enable to enable
the screen saver.
===============================================================
Errors Occur When Running the NAS Reinstallation Console
===============================================================
Problem:
When running the NAS Reinstallation console, errors state that either the
user/group could not
be created or that the share could not be created. However, in the users and
groups folder, the
user NASUser and group NASGroup and/or share NAStemp
also exist on the volume selected.
Cause:
If the system was accidentally shut down before the Reinstallation Console
was closed, the
reinstallation console cannot remove the user, group and the share files
from your system.
Solution:
Exit the NAS Reinstallation console before shutting down the system,.
Manually delete the user
NASUser, the group NASGroup and all the contents of, including
the folder NAStemp before
running the NAS Reinstallation console again.
===============================================================
Incorrect LED Status Displays After Hot-Plugging a Hard Drive
===============================================================
Problem:
After hot-plugging a hard drive on a hardware RAID NAS system, the drive LED
may not change
from blinking amber (drive failure) to green or blinking green (volume
resynching).
Cause:
In some instances, Dell OpenManage Array Manager may not be notified of a
drive status change
during a drive hotplug.
Solution:
Perform a rescan in Array Manager after inserting a new hard drive. The LED
status will be updated
correctly.
===============================================================
USB Key Preparation Utility Does Not Recognize The USB Key
===============================================================
Problem:
After inserting a USB key in the system, the Dell PowerVault USB Preparation
utility does not
recognize any valid USB keys and does not continue.
Cause:
The utility looks for a valid partition on the USB key before recognizing it
as a valid device. This is
done as a precaution so the system does not accidentally delete the wrong
USB device.
Solution:
En sure that there is a valid partition on the USB key that spans the entire
available space
on the USB key.
===============================================================
Event Log Indicates LDM Service Failure, VDS Provider Failure
===============================================================
Problem:
After a drive failure or when hot-plugging a hard drive in a software RAID
NAS system, the
Windows Logical Disk Management service stops responding and the event log
reports either an
LDM service failure or a VDS provider failure.
Cause:
This is a problem with the Microsoft LDM service.
Solution:
If you see this behavior, restart the system. For more information about
this error, go to the
Microsoft Knowledgebase website.
===============================================================
Selecting the Boot Operating System
===============================================================
Problem:
On software RAID systems, when booting from the pristine operating system
(the D: volume),
you may see two options boot from Windows Server 2003, or boot from the
mirror image
of the operating system. After 30 seconds, Windows Server 2003,
Standard is automatically chosen..
Cause:
This is caused by the Microsoft LDM service.
Solution:
If this condition occurs, restart the system. For more information about
this error, go to the
Microsoft Knowledgebase website.
===============================================================
Rsass.exe Error
===============================================================
Problem:
On software RAID systems, when booting from the pristine operating system
(the D: volume),
you may see an RSASS.EXE error and the system might automatically
reboot.
Cause:
This may occur because you are booting off volume D: instead of volume C:.
Solution:
Take no action. When the system reboots, you can recover your data, and then
reinstall your system.
===============================================================
Cannot Update SCSI Hard Drive Firmware on
PowerVault 745N NAS System
===============================================================
Problem:
You cannot update the SCSI
hard drive firmware in a SCSI storage system such as PV220S
which is attached to the
PowerVault 745N because the NAS system doesnt have floppy drive
support.
Cause:
In some instances to update
the firmware on a device attached to the PowerVault
745N you
need to create a floppy diskette and boot to it.
In this case you cant perform the hard drive
firmware update because the
PowerVault 745 NAS system doesnt have floppy drive support.
Solution:
Please perform the following
steps to update your SCSI hard drive firmware.
NOTE:
This procedure may take several minutes to complete. Please
ensure that you have met
the requirements and can view all hidden files and folders prior to
completing the following steps.
- Download the latest hard drive firmware from
Dells support website to a client with a
floppy drive
-
Run the executable to extract the files
to a floppy diskette on the client with a floppy drive
- Prepare the USB Key, which was provided with your
NAS system, for the reinstallation
(Please see the System Administrators Guide on how to prepare
the USB Key)
- Copy all the files from the floppy diskette in
step 2 to the USB key and replacing USB key
system files if prompted. (There might be some system files on the
floppy which may be
hidden, please change Windows Explorer viewing option to see hidden
files and copy those
files too.)
-
Shutdown your NAS system and insert the
USB key
- Configure your NAS system to
boot to the USB key (Please see the System
Administrators
Guide on how to boot to the USB key)
- Follow the onscreen instructions to update the
firmware
- Remove the USB key and reboot
the system
Different drive vendors (IBM, Seagate etc.) use different drive firmware
utilities.
Therefore, depending on which brand of drives are
being used, will dictate which
respective firmware flash utility is needed.
Accordingly, the flash utility will locate the
supported hard drive model(s) in the system and
update only those hard drives. If
multiple brands of hard drives are installed, you
must repeat step 1-7 for each brand.
NOTICE:
This procedure will overwrite the system files on your USB key
therefore
you will need to prepare the USB key again for the reinstallation of your
NAS system.
Requirements:
· A client system with CD and floppy drive running
the Windows 2000 (Professional
or Server Family), Windows 2003, or Windows XP operating system
· 64-MB USB Key
included with your NAS system
· Resource
CD included with your NAS system
·
Internet access.
===============================================================
USB Key Preparation Utility Changed the USB
Key Capacity to 55MB
===============================================================
Problem:
After using the Dell
PowerVault USB Key Preparation Utility, the USB
memory key capacity
changed to 55MB.
Cause:
The USB Key Preparation
Utility deletes all existing partitions and data on your USB key and
creates a new 55MB partition containing the
reinstallation tools.
Solution:
This is working as designed. The USB memory
key shipped with your PowerVault 745N
NAS system should only be use with the
reinstallation utility. Other use cases or features
are not supported.
===============================================================
On a
System with DRAC 3/XT Menus or Dialogs Boxes May Display Junk Characters
===============================================================
Problem:
When running console redirection from a DRAC3/XT
controller, some dialog boxes may display
junk messages.
Cause:
This behavior is
encountered if the systems language is set to non-Unicode language and the
"System Language for the non-Unicode Applications" is set to English.
Solution:
Manually change the "Language for
non-Unicode Programs" settings to the same language as the
language use by the server. For example, if the server
language is set to Simple Chinese, the
"Language for Non-Unicode Programs" should be set to Simple
Chinese as well. Failing to change
the setting can result in display of garbage characters in
the UI of the application.
To change the "Language for non-Unicode
Programs", perform the following:
-
Go to Start Menu --> Settings -->
Control Panel
-
Click on Regional and Language
Options
-
Click on the Advanced tab
-
Under Language for non-Unicode
programs, select the language version of non-Unicode
programs to match your system language.
-
Click OK.
-
Follow
the on-screen instruction. The system will prompt you to reboot, click
YES to reboot
and complete the changes.
===============================================================
Update.bat file does not exist
===============================================================
Problem:
Update. bat file does not exist in the C:\Dell\install\sysmgmt
directory on system with Dell
OpenManage version 4.1.
Cause:
After a DRACIII/XT card is added to or removed from the
system, you must reinstall the Dell
OpenManage Server Administrator software. To reinstall the software, the
Reinstalling the RAC
Software section of the PowerVault 745N Administrators Guide indicates that
you must run the
update.bat file located in the C:\Dell\install\sysmgmt directory. However,
that file is missing from
the specified location. To reinstall the Dell OpenManage Server
Administrator software, you must
run the install.bat file instead.
Solution:
Please perform the following
steps to update your Dell OpenManage Server Administrator software.
NOTE: Immediately after installing the DRAC
controller in your PV745N, you must allow the Plug
and Play (PnP) feature to detect and install the appropriate device driver
before proceeding to the
next 3 steps. This may take a few minutes to complete.
-
Browse
to the C:\Dell\install\sysmgmt directory
-
Double-click the file named install.bat. The Dell OpenManage Server Administrator software
reinstalls. The
reinstallation may take several minutes.
- When
the reinstallation completes, reboot your NAS system.
=================================================================
Dell OpenManage Server Administrator Link on the
NAS Manager Does Not Work
=================================================================
Problem:
Server Administrator Link on the PV745N NAS Manager
does not work .
Description:
On a Dell PowerVault PV745N, if the NAS Manager is
accessed via Internet Explorer using the
IP address of the NAS system then Dell OpenManage Server Administrator (OMSA)
is
launched from the NAS Manager, 'A Page Cannot be Displayed' error is shown
in the browser.
This error is displayed if the client computer is not in same domain as the
NAS system or when the
DNS server does not have an entry for the NAS device in its zone database.
Root Cause:
The Server Administrator link in the NAS Manager calls
an .ASP script that uses a COM object
to determine the host name for the OMSA URL. The COM object relies on the
DNS reverse
lookups if the name provided is an IP address. Since there is no HOSTS or
DNS entry for the
NAS device in the client's DNS server, the COM object returns something that
is not usable.
Solution:
Perform either of the following solutions to resolve
this issue:
- Access Open Manage Server Administrator Using
the NAS IP Address
Access Server Administrator
directly by typing https:\\<NAS_System_IP>:1311 on a
web browser, where <NAS System IP> is the IP address of the NAS system.
- Add an entry in the client system's host file
for the NAS system
Add an entry in the client
system's host file for the NAS system.
=================================================================
Remote Console using the Remote Access Controller is
not available on PV745N
=================================================================
Problem:
When attempting to use Console Redirect on a PV745N HW
RAID configuration a warning is
displayed: Warning: Remote Console is not
available. Furthermore, if diagnostics on the
DRAC III/XT are run from OpenManage they fail with the message: Internal Error: Unable to
access the
RAC device. Please make sure the RAC component is installed correctly and
the
services are running. If the problem persists, quit all nonessential
applications using the device
and run the test again.
Root Cause:
During RAC3 installation, the modem is disabled and
enabled for the default name of the modem
to be changed to RAC PPP
connection Using RACPORT after modem driver installation. The
OS fails to
recognize the modem name change and the installer code is not able to find
modem
device to establish the connection.
Solution:
From the command prompt run the command installppp
createRacConnection. The following
message will be displayed confirming
that the installation was successful:
Installing PPP connection
Successfully Installed the RAC connection
.
Information in this document is subject to change without notice.
(C) 2005 Dell Inc. All rights reserved.
Reproduction in any manner whatsoever without the written permission of Dell
Inc. is
strictly forbidden.
Trademarks used in this text: Dell, Dell OpenManage,
PowerEdge, and PowerVault, are trademarks of Dell Inc;
Microsoft and Windows are registered trademarks of
Microsoft Corporation. Other trademarks and trade
names may be used in this document to refer to either the entities claiming
the marks and names or their
products. Dell Inc. disclaims any proprietary interest in trademarks and
trade names other than its own.
October 2005